CocoaPods安装ENOENT错误

ENOENT错误:

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/pathname.rb:422:in 'open': No such file or directory - /Users/test/./repos (Errno::)
from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/pathname.rb:422:in 'foreach'
from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/pathname.rb:422:in 'children'
from /Library/Ruby/Gems/2.0.0/gems/-0.35.0/lib//sources_manager.rb:63:in 'all'
from /Library/Ruby/Gems/2.0.0/gems/-0.35.0/lib//user_interface/error_report.rb:130:in 'repo_information'
from /Library/Ruby/Gems/2.0.0/gems/-0.35.0/lib//user_interface/error_report.rb:34:in 'report'
from /Library/Ruby/Gems/2.0.0/gems/-0.35.0/lib//command.rb:58:in 'report_error'
from /Library/Ruby/Gems/2.0.0/gems/claide-0.7.0/lib/claide/command.rb:300:in 'handle_exception'
from /Library/Ruby/Gems/2.0.0/gems/claide-0.7.0/lib/claide/command.rb:274:in 'rescue in run'
from /Library/Ruby/Gems/2.0.0/gems/claide-0.7.0/lib/claide/command.rb:264:in 'run'
from /Library/Ruby/Gems/2.0.0/gems/-0.35.0/lib//command.rb:45:in 'run'
from /Library/Ruby/Gems/2.0.0/gems/-0.35.0/bin/pod:43:in `'
from /usr/bin/pod:23:in 'load'
from /usr/bin/pod:23:in 'main'

 

建议:

sudo rm -rf ~/.cocoapods/
pod setup

 

知识共享许可协议
本作品《CocoaPods安装ENOENT错误》verynix创作,采用知识共享署名-非商业性使用-禁止演绎 3.0 Unported许可协议进行许可。
基于verynix.com上的作品创作。
Permissions beyond the scope of this license may be available at verynix.com.

本文链接: http://verynix.com/cocoapods-enoent-error.html

Post Footer automatically generated by wp-posturl plugin for wordpress.

Leave a Reply

Your email address will not be published. Required fields are marked *